Проброс влана на JuniperMX80 через MPLS

Обычный вариант, используется targeted ldp сессия (без rsvp):

interfaces {
 ge-1/1/2 {
 vlan-tagging;
 mtu 1600;
 encapsulation flexible-ethernet-services;
 unit 698 {
 description " -- TEST vlan over mpls";
 encapsulation vlan-ccc;
 vlan-id 698;
 family ccc;
 }
}
}
 }
 interface all;
 }
 ospf {
 area 0.0.0.0 {
 interface all;
 }
 }
 ldp {
 interface lo0.6;
 }
 l2circuit {
 neighbor 3.3.3.3 {
 interface ge-1/1/2.698 {
 virtual-circuit-id 1;
 }
 }
 }
}

Второй вариант, c помощью VPLS, LDP сигнализации и irb интерфейсом. IRB можно сделать только с VPLS.
PE1:

set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
set protocols ldp interface all disable
set protocols ldp interface ae0.27
set protocols ldp interface ae0.28
set protocols ldp interface lo0.

set protocols mpls interface ae0.27
set protocols mpls interface ae0.28
set protocols mpls interface all disabl

set interfaces ae0 unit 27 description "-- interconnect-1"
set interfaces ae0 unit 27 vlan-id 27
set interfaces ae0 unit 27 family inet mtu 1500
set interfaces ae0 unit 27 family inet address 1.1.1.164/28
set interfaces ae0 unit 27 family mpls mtu 1550
set interfaces ae0 unit 28 description "-- interconnect-2 Backup"
set interfaces ae0 unit 28 vlan-id 28
set interfaces ae0 unit 28 family inet mtu 1500
set interfaces ae0 unit 28 family inet address 1.1.1.180/28
set interfaces ae0 unit 28 family mpls mtu 155

set interfaces ae0 unit 698 description " -- TEST vlan over mpls"
set interfaces ae0 unit 698 encapsulation vlan-vpls
set interfaces ae0 unit 698 vlan-id 698
set interfaces irb unit 698 description "-- TEST"
set interfaces irb unit 698 family inet mtu 1500
set interfaces irb unit 698 family inet address 10.22.0.3/24
set routing-instances vpls698 instance-type vpls
set routing-instances vpls698 vlan-id 698
set routing-instances vpls698 interface ae0.698
set routing-instances vpls698 routing-interface irb.698
set routing-instances vpls698 protocols vpls vpls-id 698
set routing-instances vpls698 protocols vpls neighbor 1.1.2.122

PE2:

set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
set protocols ldp interface all disable
set protocols ldp interface irb.27
set protocols ldp interface irb.28
set protocols ldp interface lo0.

set protocols mpls no-propagate-ttl
set protocols mpls interface irb.27
set protocols mpls interface irb.28
set protocols mpls interface all disable

set interfaces irb unit 27 description "-- interconnect-1"
set interfaces irb unit 27 family inet mtu 1500
set interfaces irb unit 27 family inet address 1.1.1.165/28
set interfaces irb unit 27 family mpls mtu 1550
set interfaces irb unit 28 description "-- interconnect-2 Backup"
set interfaces irb unit 28 family inet mtu 1500
set interfaces irb unit 28 family inet address 1.1.1.179/28
set interfaces irb unit 28 family mpls mtu 1550

set interfaces ae0 unit 698 description " -- TEST vlan over mpls"
set interfaces ae0 unit 698 encapsulation vlan-vpls
set interfaces ae0 unit 698 vlan-id 698
set routing-instances vpls698 instance-type vpls
set routing-instances vpls698 interface ae0.698
set routing-instances vpls698 protocols vpls vpls-id 698
set routing-instances vpls698 protocols vpls neighbor 1.1.2.123

 

Запись опубликована в рубрике Juniper, Блог с метками , . Добавьте в закладки постоянную ссылку.